Browser requirements for WorldShare Interlibrary Loan

Tip of the Week February 13, 2014

Beginning with the February release of new WorldShare ILL features, OCLC no longer supports use of Microsoft® Internet Explorer Version 8 with WorldShare ILL.

OCLC WorldShare® Interlibrary Loan is tested with specific browser versions in conjunction with each release of new functionality, to ensure the best possible experience for users of the service. Newer browser versions are needed to enable use of the new and expanded features of WorldShare ILL. This tip summarizes current browser requirements, including the end of support for use of Internet Explorer version 8 with WorldShare ILL.

The browsers and versions most recently tested with WorldShare® Interlibrary Loan are:

  • Mozilla Firefox® 26.0 (preferred browser)
  • Google Chrome version 33.0.1700.76 M
  • Microsoft® Internet Explorer versions 9.0 or 10.0

END OF SUPPORT FOR USE OF INTERNET EXPLORER 8 WITH WORLDSHARE ILL

Beginning with the February 9, 2014 release of new features to WorldShare ILL, OCLC no longer tests WorldShare ILL with Internet Explorer 8. This change is in line with Microsoft's plan to end support for Windows XP on April 8, 2014. The service will continue to work with Internet Explorer 8; however, over time users will likely experience degradation of functionality.

This decision has been made for several reasons:

  • Microsoft requires users to update from IE 8 to IE 9 through Windows Update (although users are able to opt out of this update).
  • Internet Explorer 8 does not support HTML 5. This hampers our ability to provide a contemporary, rich user experience in WorldShare ILL.
  • Modern browsers provide better security and performance.
  • Supporting out-of-date browser versions adds to development and support time. This has an impact on how quickly new features can be delivered on WorldShare ILL.

Do you use Internet Explorer 8 now?

  • If your institution plans to continue unsupported use of Windows XP after April 8, 2014, we highly recommend that you install either Mozilla Firefox or Google Chrome for an improved experience with WorldShare ILL.

  • If you are currently limited to using Internet Explorer 8, now is the time to begin working with your technical staff to upgrade your browsers to Internet Explorer 9 or 10, Firefox or Chrome.

If you are not sure which browser is in use at your library, you can use this online tool to find out.
A Windows life cycle fact sheet is available on the Microsoft site.

For additional assistance
Contact OCLC Customer Support
at support@oclc.org or OCLC Support in your region for assistance with WorldShare ILL.

P.S. Previous WorldShare ILL “Tip of the Week” messages are available for your review on the OCLC website.

We are a worldwide library cooperative, owned, governed and sustained by members since 1967. Our public purpose is a statement of commitment to each other—that we will work together to improve access to the information held in libraries around the globe, and find ways to reduce costs for libraries through collaboration. Learn more »