Ticket Authentication with PHP

Minimum version required

The options described in this document require EZproxy 3.0f GA (2004-10-26) or later.

Overview

To create tickets with PHP, download ezproxyticket.txt which provides support for generating EZproxy ticket URLs. The .txt extension on this file is only needed to for downloading; once you download the file, you should replace this extension with "php". You should place this file in your PHP include directory or else place it in the same directory where you will place your scripts that create tickets.

For an example of using this library to create tickets, see: ticketdemo.txt. The .txt extension on this file is only needed to for downloading; once you download the file, you should replace this extension with "php".