FAQ

  • Flex Loader: ALTO version compatibility (8/20/2011)

Need assistance for CONTENTdm?

Flex Loader: ALTO version compatibility

Last review: August 20, 2011

Description: As of Flex Loader 6.1, the ALTO v1.4 standard is supported. To use version 2.0, you need to modify the namespace specifications.

As of Flex Loader 6.1, the ALTO v1.4 standard is supported. ALTO v2.0 has not been formally tested in the 6.1 release. It may still be possible to use ALTO v2.0 input files with Flex Loader 6.1.

The ALTO standard is currently at version 2.0. It is backwards-compatible with version 1.4, except as noted on the Library of Congress ALTO page (http://www.loc.gov/standards/alto/):

"The current 2.0 version of the schema entirely implements the previous 1.4 version of the schema with two exceptions: the addition of a loc.gov namespace URI, and an updated URI import reference for the inclusion of XLink functionality."

If you have ALTO 2.0 files to process in Flex Loader 6.1, you can modify the namespace specifications to be more general. This will allow Flex Loader to process the files as though they were version 1.4.

For example, change the tag from:

<alto xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.loc.gov/standards/alto/ns-v2#" xsi:schemaLocation="http://www.loc.gov/standards/alto/ns-v2# http://www.loc.gov/standards/alto/alto-v2.0.xsd" xmlns:xlink="http://www.w3.org/1999/xlink">

to:

<alto xmlns="http://schema.ccs-gmbh.com/ALTO" xmlns:xlink="http://www.w3.org/1999/xlink">