Basic documentation

  • Aspectos básicos: Administración de archivos locales

Aspectos básicos: Administración de archivos locales

Administración de archivos locales para la catalogación fuera de línea

Acerca de los archivos locales

  • ¿Qué son los archivos locales?
    • Los archivos locales del cliente de Connexion están en su estación de trabajo, o pueden estar en una unidad de red para permitir el acceso compartido.



      Nota: Más de una persona puede usar un archivo compartido al mismo tiempo, pero sólo un usuario a la vez puede abrir un registro en un archivo local.
    • Utilice los archivos locales para guardar registros bibliográficos y de autoridad, para crear y almacenar datos constantes bibliográficos y de autoridad, efectuar acciones en los registros o ingresar a WorldCat o a la Biblioteca del Congreso para realizar búsquedas en archivos de autoridad a fin de llevar a cabo un procesamiento por lote.
  • Tipos de archivos locales, nombres predeterminados y ubicaciones.

    El cliente admite cuatro tipos de archivos locales. Cuando instala el cliente, el programa de instalación crea un archivo local predeterminado para cada tipo de archivo, listo para que usted le agregue registros:
    • Archivo guardar bibliográfico: DefaultBib.bib.db
    • Archivo de datos constantes bibliográficos: DefaultBibCD.bibcd.db
    • Archivo guardar de autoridad: DefaultAuth.auth.db
    • Archivo de datos constantes de autoridad: DefaultAuthCD.authcd.db

    La ubicación predeterminada para los archivos locales es:

    • X:\Documents and Settings\[nombre del usuario]\Application Data\OCLC\Connex\, donde X es la letra de su disco rígido
  • Archivos múltiples.

    Cree archivos adicionales separados de cualquier tipo para realizar actividades de catalogación específicas o para los diferentes miembros del personal.
  • Límite de registros.

    Cada archivo local puede almacenar hasta 9.999 registros.
  • Adición de registros.

    Los registros que usted guarde en un archivo local se anexan a los registros existentes en el archivo.
  • Administrador de archivos locales. El cliente le proporciona un administrador de archivos locales (menú Archivo) para que usted pueda:
    • Definir rutas de archivos locales
    • Crear varios archivos locales
    • Eliminar archivos locales
    • Establecer un archivo local como predeterminado
    • Asignar una autorización y contraseña individual a un archivo guardar local
    • Ver el número de registros en un archivo local seleccionado por estados
    • Configurar opciones para que se efectúen copias de seguridad de los archivos locales automáticamente
    • Ver los informes del procesamiento por lote
  • Parámetros de catalogación.



    Además, en la pestaña Herramientas > Opciones > General, puede seleccionar opciones de catalogación para archivos locales que son diferentes a las del perfil de catalogación asociado a su autorización de inicio de sesión. Usted puede definir:
    • El código de existencia de la biblioteca y el símbolo de la institución o (para las bibliotecas con autorización de NACO) el código de identificación MARC
    • Esquema de clasificación

Notas:

  • Los registros que se encuentran en los archivos locales no caducan.
  • OCLC recomienda que conserve la configuración predeterminada para que se realicen copias de seguridad de los archivos locales automáticamente, de modo que sus datos estén protegidos. Si un archivo local se vuelve inutilizable, usted puede renombrar la copia de seguridad para que sea el archivo actual.

Catalogación en línea/fuera de línea con archivos locales

  • Usted puede guardar registros en el archivo guardar bibliográfico o de autoridad local cuando efectúe una de las siguientes acciones:
    • Realizar búsquedas en WorldCat o en el archivo de autoridad de la Biblioteca del Congreso interactivamente o a través de la búsqueda por lote
    • Realizar búsquedas en el archivo guardar bibliográfico o de autoridad en línea
    • Importar registros
    • Crear registros
    • Mover o copiar registros desde otros archivos locales
  • Guarde datos constantes bibliográficos o de autoridad en los archivos locales cuando ejecute una de las siguientes acciones:
    • Crear datos constantes
    • Realizar búsquedas en el archivo de datos constantes en línea
  • Mediante el uso de un archivo local, trabaje en los registros mientras está:
    • En línea o fuera de línea para:
      • Crear registros
      • Crear datos constantes
      • Editar registros y aplicar datos constantes o insertar símbolos diacríticos y caracteres especiales o cadenas de texto
      • Ejecutar acciones inmediatas en registros únicos o registros seleccionados en una lista
      • Copiar o mover registros de un archivo guardar a otro
    • Fuera de línea, sólo para:
      • Completar un procesamiento local: exportar registros, imprimir registros o imprimir etiquetas
      • Marcar registros con acciones para realizar un procesamiento por lote
      • Ingresar claves de búsqueda por lote
  • Utilizar archivos locales para realizar un procesamiento por lote



    Para obtener más información sobre el procesamiento por lote, consulte:
    • "Ingreso de claves de búsqueda por lote en WorldCat"
    • "Ingreso de claves de búsqueda por lote en el archivo de autoridad de la Biblioteca del Congreso"
    • "Efectuar acciones en registros bibliográficos para el procesamiento por lote"
    • "Efectuar acciones en registros de autoridad para el procesamiento por lote"
    • "Ejecutar un procesamiento por lote"

Adición de ubicaciones y/o creación de archivos locales

Es posible que usted desee:

  • Crear varios archivos locales empleados para diferentes propósitos o por varios miembros del personal de la biblioteca y ubicar distintas categorías de archivos en diferentes unidades o en carpetas separadas
  • Colocar uno o más archivos locales en una unidad de la red a fin de compartirlos con varios miembros del personal

Para agregar una nueva ubicación para archivos locales:

  Acción
1 En el menú Archivo, haga clic en Administrador de archivos locales o presione <Alt><F><F>.
2 Haga clic en Configurar rutas.
3 En el cuadro de diálogo Configurar rutas de archivos locales, haga clic en Agregar.
4 En el cuadro de diálogo Navegar por carpetas, navegue hasta la carpeta que desea designar como ubicación, o navegue hacia otra ubicación y cree una carpeta nueva al hacer clic en Nueva carpeta e ingrese un nombre para ésta.
5 Haga clic en Aceptar o presione <Enter> para agregar la nueva ubicación, o haga clic en Cancelar.



Resultados:El nombre completo de la ruta de la nueva ubicación aparece en el cuadro de diálogo Configurar rutas locales. Haga clic en Aceptar para cerrar el cuadro de diálogo.


Para crear un nuevo archivo local y, opcionalmente, una nueva ubicación:

  Acción
1 En el cuadro de diálogo ( Archivo > Administrador de archivos locales), en Escoger tipo de archivo, haga clic en el tipo de archivo que desea crear. Seleccione una de las siguientes opciones:
  • Bibliográfico
  • Autoridad
  • Datos constantes bibliográficos
  • Datos constantes de autoridad
2 Haga clic en Crear archivo.
3 En el cuadro de diálogo Abrir de Windows, acepte la ubicación predeterminada ( X:\Documents and Settings\[nombre del usuario]\Application Data\OCLC\Connex\Db) y simplemente ingrese el nombre del archivo nuevo. Luego, haga clic en Abrir. O

Navegue hasta una ubicación diferente e ingrese el nombre del archivo nuevo que desea crear. Después, haga clic en Abrir y, ante el mensaje ¿Agregar ruta?, haga clic en para confirmar o en No para cancelar.

Sugerencia: No ingrese las extensiones *.bib.db, *.auth.db, *.bibcd.db ni *.authcd.db. El cliente suministra la extensión por usted.

Resultados: La ruta y el nombre del archivo que creó aparece en la lista de Archivos en el cuadro de diálogo Administrador de archivos locales.



Eliminación de un archivo local

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), en Escoger tipo de archivo, haga clic en el tipo de archivo que desea eliminar.
2 En la lista de Archivos, haga clic en el archivo que desea eliminar y luego haga clic en Eliminar archivo.
3 Haga clic en para confirmar o en No para continuar sin eliminar el archivo.



Advertencia: Una vez que lo haya eliminado, usted no podrá recuperar el archivo. El cliente lo eliminará inmediata y permanentemente. El archivo no se enviará a la Papelera de reciclaje de su estación de trabajo.


Selección de un archivo local predeterminado

Cuando instala el programa, el cliente crea un archivo local predeterminado para cada tipo de archivo admitido. Para cambiar el predeterminado:

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), en Escoger tipo de archivo, haga clic en el tipo de archivo para el que desea establecer un archivo predeterminado.
2 En la lista de Archivos, el archivo predeterminado actual está marcado con una tilde. Haga clic en el archivo que desea establecer como predeterminado, y luego haga clic en Configurar como predeterminado



Resultados: Ahora, la tilde aparecerá al lado del archivo que seleccionó.
3 Cuando haya finalizado, haga clic en Cerrar.


Asignación de una autorización/contraseña individual a un archivo local (opcional)

  • Obligatorio. Para ejecutar el procesamiento por lotes, debe definir: Una autorización general predeterminada en:
    • Una autorización general predeterminada en:

      Herramientas > Opciones > Autorizaciones

      O
    • Una autorización predeterminada específicamente para un archivo local en:

      Archivo > Administrador de archivos locales
  • Si ingresa una autorización o una contraseña para un archivo local:
    • El cliente cancelará cualquier autorización o contraseña general predeterminada que usted configure en Herramientas > Opciones > Autorizaciones, y utilizará la que usted asignó a ese archivo local.
    • La autorización o contraseña para el archivo local siempre ocupa el primer lugar de la lista de la ventana de inicio de sesión del sistema OCLC (facilita el procesamiento por lotes), independientemente de que tenga abierto o no el archivo local.
  • Si no ingresa una autorización o una contraseña para un archivo local, el cliente utilizará la autorización o contraseña predeterminada que usted haya establecido en Herramientas > Opciones > Autorizaciones , al iniciar sesión o ejecutar el procesamiento por lotes utilizando el archivo.

Resumen: Es optativo asignar una autorización predeterminada a un archivo local pero, si no lo hace, deberá asignar una autorización general predeterminada para poder ejecutar el procesamiento por lotes.

Para asignar una autorización/contraseña a un archivo local:

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), en Escoger tipo de archivo, seleccione Bibliográfico o de Autoridad (no disponible para archivos de datos constantes locales).
2 En la lista de Archivos, haga clic en el nombre del archivo guardar local al que desea asignarle una autorización/contraseña, y luego haga clic en Autorización.
3 En el cuadro de diálogo Asignar autorización y contraseña, ingrese una autorización y una contraseña.

O

Elimine cualquier autorización/contraseña que haya ingresado para el archivo y deje los cuadros vacíos si desea que el cliente emplee la autorización y contraseña predeterminadas de Herramientas > Opciones > Autorizaciones



Predeterminado: La autorización y la contraseña están en blanco. El cliente utiliza la autorización/contraseña predeterminada que usted ingresó en Herramientas > Opciones > Autorizaciones para el inicio de sesión interactiva o por lote para el archivo seleccionado.
4 Haga clic en Aceptar para asignarle la autorización/contraseña al archivo, o haga clic en Cancelar para cancelar la asignación.



Resultados:
  • Si se asigna una, la autorización/contraseña es utilizada para el inicio de sesión interactiva y para el inicio de sesión de procesamiento por lote para este archivo local.
  • Para el inicio de sesión interactiva, la autorización/contraseña asignada aparece primera en la lista del cuadro de diálogo Inicio de sesión en Connexion de OCLC.


Definición de un código de existencia de la biblioteca y del símbolo de la institución o de un código de identificación MARC para la catalogación fuera de línea

  • Obligatorio. Para la catalogación fuera de línea, usted deberá definir un código de existencia de la biblioteca y un símbolo de la institución.
  • El cliente utiliza dicho código y símbolo que usted asigna para los formularios de trabajo bibliográficos, los formularios de trabajo de datos bibliográficos constantes y los registros importados en un archivo local.
  • Requerido para las bibliotecas con autorización de NACO. Debe definir un código de identificación MARC individual para usar con los formularios de trabajo de autoridad y los registros importados.

Para definir la información requerida para la catalogación fuera de línea:

  Acción
1 En el menú Herramientas, haga clic en Opciones o presione <Alt><T><O>, y luego haga clic en la pestaña General.
2 Haga clic en Opciones de Catalogación fuera de línea.
3

En la casilla Código de existencia de la biblioteca , ingrese un código.

En la casilla Símbolo de la institución , ingrese un símbolo.

En la casilla Código de identificación MARC , ingrese un código (sólo requerido para los participantes de NACO).
4 Haga clic en Aceptar o Cancelar.
5 En la pestaña General, haga clic en Aceptar para guardar los cambios.

O

Haga clic en Cancelar (cierra la ventana Opciones).

O

Haga clic en Aplicar para guardar los cambios y mantener la ventana Opciones abierta.


Definición de un esquema de clasificación

Para la catalogación en línea, usted puede definir un esquema de clasificación individual para utilizarlo con etiquetas y suministrar el campo de signatura topográfica en blanco para los registros bibliográficos y los formularios de trabajo en los archivos guardar bibliográficos locales (no se utiliza para los registros y los formularios de trabajo de datos constantes).

Nota: Cuando usted está conectado, el cliente usa el esquema de clasificación asociado con la autorización y la contraseña de inicio de sesión que usted utiliza.

  Acción
1 En el menú Herramientas, haga clic en Opciones o presione <Alt><T><O>, y luego haga clic en la pestaña General.
2 Haga clic en Opciones de Catalogación fuera de línea.
3 En la lista Esquema de clasificación, seleccione uno de los esquemas siguientes:
  • Biblioteca del Congreso ( predeterminado)
  • Dewey
  • Biblioteca Nacional de Medicina
  • Canadiense
  • Gobierno
  • Biblioteca Nacional de Agricultura
4 Haga clic en Aceptar o Cancelar .
5 En la pestaña General, haga clic en Aceptar para guardar los cambios.

O

Haga clic en Cancelar para cancelar los cambios.

O

Haga clic en Aplicar para guardar los cambios y mantener la ventana Opciones abierta.


Visualización de los informes del procesamiento por lote

Desde el administrador de archivos locales, usted puede desplegar los informes del procesamiento por lote correspondientes a las ejecuciones por lote más actuales:

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), en Informes por lote, haga clic en el tipo de informe que desea ver, que puede ser:
  • Búsquedas
  • Acciones en línea
  • Impresión de etiquetas
  • Exportaciones

    Notas:

    • El procesamiento por lote sólo se encuentra disponible para los archivos guardar locales (no está disponible para los datos constantes locales)
    • Procesamiento de existencias por lotes según los números de OCLC ( Por lote > Existencias según el Número de OCLC ) produce un informe por lotes temporario. No podrá recuperarlo después de cerrarlo.

    Resultados: Los informes por lote se abrirán detrás del Administrador de archivos locales. Si usted selecciona varios registros, éstos se abrirán simultáneamente uno detrás del otro.

2 Haga clic en Cerrar para cerrar el cuadro de diálogo Administrador de archivos locales.
3 Cuando haya finalizado con los informes por lote, haga clic en el ángulo superior derecho de cada informe para cerrarlo.


Visualización de las estadísticas de un archivo local

Nota: Si realiza el siguiente procedimiento, sólo podrá visualizar las estadísticas pero no recuperar los registros. Para visualizar los estados y recuperar registros, usted debe recurrir a Catalogación [o Autoridades] > Mostrar > Por estado de archivo guardar local.

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), en Escoger tipo de archivo, seleccione Bibliográfico o de Autoridad (no disponible para archivos de datos constantes locales).
2 En la lista de Archivos, haga clic en el nombre del archivo guardar local para el que desea ver el número de registros con estados específicos.
3 Haga clic en Estadísticas.



Resultados:

La Lista de estados para el archivo especificado se abrirá y mostrará lo siguiente para un archivo bibliográfico local:
  • El número de registros con los estados Terminado, Interrumpido o Listo para las siguientes acciones:

    Borrar existencias

    Exportar

    Etiqueta

    Producir

    Reemplazar

    Enviar

    Actualizar existencias

    Validar
  • El número de registros con los siguientes estados de fuente:

    Derivado

    Extraído

    Importado

    OCLC

    Rastreador

    URL en rastreador

    Formulario de trabajo
  • El número de registros con los siguientes estados de flujo de trabajo:

    Terminado

    En proceso

    En revisión

    Nuevo
  • El número total de registros en el archivo

O muestra lo siguiente para un archivo de autoridad local:

  • El número de registros con los estados Terminado, Interrumpido o Listo para las siguientes acciones:

    Agregar

    Exportar

    Reemplazar

    Enviar

    Validar
  • El número de registros con los siguientes estados de flujo de trabajo:

    Terminado

    Importado

    En proceso

    En revisión

    Nuevo
  • El número total de registros en el archivo
4 Haga clic en Aceptar para cerrar el cuadro de diálogo Lista de estados.


Copia o movimiento de registros del archivo local

  Acción
1 Mientras un registro del archivo local está abierto o hay registros seleccionados en la lista del archivo local, en el menú Acción, haga clic en Copiar registro o presione <Alt><A><Y>.

O

Haga clic en Mover registro o presione <Alt><A><V>.

El comando Copiar coloca una segunda copia de los registros en el archivo que usted selecciona y deja la primera en el archivo original.

El comando Mover quita los registros del archivo original y los coloca en el archivo que usted selecciona.

Notes:

  • Registros de autoridad bloqueados: Los registros de autoridad bloqueados no pueden copiarse Sólo las bibliotecas asociadas a NACO pueden copiar los registros de autoridad bloqueados.
  • Registros de datos constantes:
    • Los registros de datos constantes locales no pueden copiarse dentro del mismo archivo, dado que cada registro debe tener un nombre exclusivo. Para copiar un registro dentro del mismo archivo, utilice Editar > Derivar > Nuevos datos constantes para crear una copia con un nombre diferente.
    • Los registros de datos bibliográficos constantes locales de una lista pueden copiarse o moverse a otro archivo local o al archivo de datos constantes en línea, pero usted no puede mover varios registros seleccionados de una lista de datos constantes en línea a un archivo local.
2 Optativo. Haga clic en Administrador de archivos locales para abrir el cuadro de diálogo Administrador de archivos locales si desea crear un nuevo archivo. Luego, haga clic en Cerrar para regresar al cuadro de diálogo Copiar [o Mover] registro del archivo local.



Resultados: Si creó un nuevo archivo, su ruta y nombre de archivo se agregarán a la lista.
3 En el cuadro de diálogo Copiar [o Mover] registro del archivo local, haga clic en la ruta y nombre de archivo o en el archivo en el que desea copiar o mover el registro.
4 Haga clic en Aceptar para copiar o mover los registros.

O

Haga clic en Cancelar para cancelar la acción y cerrar el cuadro de diálogo.


Exportación de registros desde un archivo local

  • Cuando usted exporta registros ( Acción > Exportar) desde un archivo local mientras está fuera de línea, el cliente almacena la información de facturación, se la envía al sistema la próxima vez que usted inicia sesión y despliega un mensaje que resume la información de la exportación realizada.
  • Si usted inició sesión y cambia el archivo local predeterminado desde el administrador de archivos locales ( Archivo > Administrador de archivos locales) o desde el cuadro de diálogo Buscar en archivo guardar local bibliográfico ( Catalogación > Buscar > Archivo guardar local), el cliente envía la información de facturación correspondiente a la exportación desde ese archivo hacia el sistema, y despliega un mensaje que resume la información de la exportación realizada.

Copias de seguridad automáticas de los archivos locales

De manera predeterminada, cuando usted sale del cliente o cambia el archivo local predeterminado, el cliente realiza copias de seguridad automáticas de los archivos locales en la misma ubicación que el archivo original, pero con la extensión adicional *.bac.

Recomendación: OCLC recomienda que conserve la configuración predeterminada para proteger sus datos en caso de que un archivo local quede inutilizable. Si usted siempre tiene copias actualizadas de sus archivos, puede renombrar las copias de seguridad para convertirlas en los archivos actuales, y así recuperar sus datos.

Para verificar o cambiar la opción, o para seleccionar una ubicación diferente para las copias de seguridad:

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), haga clic en Copias de seguridad automáticas.
2 En el cuadro de diálogo Copias de seguridad automáticas de los archivos locales, haga clic en el botón que esté al lado de la opción que usted desea seleccionar. Seleccione una de las siguientes opciones:
  • No hacer copias de seguridad de los archivos locales

    Seleccione este botón si no desea realizar copias de seguridad automáticas (no recomendado).
  • Hacer copias de seguridad en la misma carpeta que el archivo original ( predeterminado)

    Conserve o vuelva a seleccionar esta opción para crear copias de seguridad automáticas con el mismo nombre del archivo original, pero con la extensión adicional *.bac. Ejemplo: DefaultBib.bib.db.bac
  • Hacer copias de seguridad de los archivos locales en [...]

    Seleccione esta opción a fin de escoger una carpeta diferente para las copias de seguridad:
    Haga clic en Navegar para buscar la carpeta que desea utilizar para las copias de los archivos locales.
    • Una vez que haya seleccionado una ubicación, el cuadro de diálogo desplegará el nombre completo de la nueva ruta.
    • El cliente colocará copias de seguridad de todos los archivos locales en una sola carpeta
3 Cuando haya finalizado, haga clic en Aceptar para guardar su parámetro, o haga clic en Cancelar para restaurar el parámetro anterior.


Advertencia: Si su parámetro establece que las copias de seguridad se realicen en la misma carpeta, y usted crea varios archivos locales en carpetas diferentes pero les da el mismo nombre, cada vez que se haga la copia de seguridad de uno de los archivos, la misma sobrescribirá la copia de seguridad anterior. Si los archivos con el mismo nombre contienen registros diferentes, usted perderá datos en la copia de seguridad.

Compactación/reparación de un archivo local

Compactación de un archivo local:

  • Elimina el espacio vacío que queda después de borrar registros o de moverlos a otro archivo. Cuando borra o mueve registros desde un archivo local, no se elimina el espacio vacío que ocuparon antes, y el tamaño del archivo continúa aumentando a menos que usted lo compacte.



    Compactación de un archivo local:
    • Después de borrar registros desde un archivo local
    • Después de mover registros a otro archivo local



      Advertencia: No puede compactar un archivo local si lo está utilizando otro miembro del personal.
  • Repara un archivo cuando usted recibe mensajes erróneos de que los registros de un archivo local están siendo usados por otra persona (desbloquea los registros "atascados").
  • Repara los índices.

Para compactar y reparar un archivo:

  Acción
1 En el cuadro de diálogo Administrador de archivos locales (menú Archivo), en Escoger tipo de archivo, seleccione el tipo de archivo y luego haga clic en el nombre del archivo local que desea compactar y/o reparar.
2 Haga clic en Compactar archivo.

Resultados: El cliente confirmará que la compactación/reparación terminó.

3 Si usted continúa recibiendo mensajes de violación por uso compartido y no puede abrir los registros del archivo, haga lo siguiente:

  1. Cierre el cliente, y luego apague y reinicie su estación de trabajo.
  2. En el Explorador de Windows, verifique si hay un archivo con la extensión *.ldb en la misma carpeta en la que se encuentra el archivo local. Ubicación

    predeterminada: X:\Documents and Settings\[nombre del usuario]\Application Data\OCLC\Connex\Db (donde X = la letra de su disco rígido)
  3. Si hay uno, elimine el archivo *.ldb y vuelva a hacer clic en el botón Compactar archivo.



    Nota: Si varias personas utilizan este archivo local, siga este procedimiento en todas las estaciones de trabajo que tengan acceso al archivo.


volver arriba