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Revision History

Date Section title Description of changes

April 2011 New guide  This guide provides an overview of batch processing within the 
Connexion client.

 It provides all basic instructions for batch processing in a single 
document.

 Batch processing itself has not changed.
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1 Batch process searches and record actions

What is batch 
processing in the 
client?

Batch processing runs searches and record actions on multiple records and/or files 
automatically all at once (in a "batch"). Batch processing in the client follows this 
general pattern:

Batch processing in the client is different from Batchload services from OCLC. In the 
Connexion client, you set up and initiate batch processing. It is under your control. 
The Batchload service, run by OCLC Batch Services staff, can process much larger 
amounts of records/data on behalf of libraries (see more about the Batchload 
service at http://www.oclc.org/us/en/batchprocessing/).

The sections below provide brief instructions for batch processing in the client. See 
the last section below for more about which client system guides have more detailed 
instructions.

Set up for batch 
processing

The table below shows the menus and commands to access settings and options 
for batch processing. In each of the windows that these commands open, click the 
Help button for detailed instructions.

Action

1 You do this:
Enter WorldCat searches and/or set actions you want to take on bibliographic 
records in your local bibliographic save file.
And/or
You enter LC authority file searches and/or set actions you want to take on authority 
records in your local authority save file.

2 You do this: Run batch processing on the local file(s) you prepared.

3 The client does this:
1. Automatically logs on to the OCLC system using a default authorization and 

password that you set up.
2. Runs the searches and/or processes actions on records.
3. Downloads records from searches.
4. Produces separate reports on the results of searches and record actions.

Go to... To ...

Tools > Options > Batch Set options for:
 Maximum number of matched records to download 

(up to 150)
 Keeping batch search keys if too many matches are 

found, no records are found, or errors occur in 
searches

 Deleting attached local holdings records and/or 
bibliographic institution records when holdings are 
deleted

 Taking export and label print actions on records in 
local files via batch processing rather than export or 
print labels immediately.

 Displaying or printing batch reports as soon as 
processing is finished
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Manage local files You use local save files on your workstation or on a shared drive for offline 
cataloging and for batch processing. This section covers the highlights of managing 
local save files for batch processing. The client provides other types of local files 
and many other functions for local file management than is covered here. See 
details in Basics: Manage Local Files.

Default local save files. At installation, the client supplies one default local save 
file for bibliographic records and one for authority records:

 Click File > Local File Manager to open the Local File Manager window and 
work with your local files, including:

—Default local bibliographic save file: DefaultBib.bib.db

—Default local authority save file: DefaultAuth.auth.db

Default file location.

 Local files are stored in X:\Documents and Settings\[your user name]\Application 
Data\OCLC\ Connex\Db (where X represents the letter of your hard drive), unless 
you change the location.

Use the Local File Manager

 Click File > Local File Manager to work with your local files, including:

—Creating multiple files. 
Many catalogers use and re-use only one bibliographic and/or one local 
authority save file. If needed, however, you can create more local files for 
different purposes or for individual staff members:

- In the Local File Manager window, under File Type, select Bibliographic or 
Authority, and click Create File. Give the file a name (the client will add the 
correct file extension, .bib.db or .auth.db) and click Open. The new file is 
added to the list. 

If you have multiple files, you must designate a file as the default to open 
and use it: Select a file in the Files list, and click Set as Default.

Batch > Process Batch; 
click Search Options

Set options to assign a My Status or apply default 
constant data to records downloaded from a search.

Required: A default logon 
authorization and 
password:

Tools > Options > 
Authorizations (general 
logon)
Or
File > Local File 
Manager; click 
Authorizations (file-
specific logon)

You must enter either a general default authorization 
and password or a local-file-specific authorization and 
password for automatic logon for batch processing.

Go to... To ...
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—Setting a logon authorization for a file.

- In the Local File Manager window, select a file in the Files list, and click 
Authorization. Enter the authorization and password you want the client to 
use when you run batch processing using that file. 

If you do not assign an authorization to a file, the client uses the 
authorization you enter and designate as the default in Tools > Options > 
Authorizations. If you do assign an authorization to a file, it overrides any 
default you have set in the Options/Authorizations window. Setting one or 
the other type of default authorization is required for batch processing.

—Viewing reports from the most current batch processing sessions.

- In the Local File Manager window, select a file in the Files list, select the 
type(s) of batch reports you want to see (Searches, Online Actions, 
Exports, and/or Label Printing) and click View Reports.

This method of viewing reports lets you see reports from any file, whether 
designated the default or not. When you view reports from Batch > View 
Reports > [report type], the reports are always from batch processing using 
the default file.

Prepare searches for 
batch processing

Enter WorldCat searches

Action

1 Click Batch > Enter Bibliographic Search Keys.

2 Check to be sure the local file file you want to use is selected in the Local File list, if 
you use more than one local authority save file.

3 In the Query box, enter a search using full search syntax, as you would enter a 
Command Line search for an interactive LC Names and Subjects authority file 
search (logged on). (See the Search Authority Files client system guide for more 
information.)

4 Optional. Select a default index in the Use default index list. The index is used for 
all searches unless you override it by including a different index in a search string.

5 Optional. Click to select the Apply default WorldCat qualifiers check box and 
enter qualifier(s) in the box. The qualifier(s) are applied to all searches unless you 
override by including different qualifier(s) in a search string.

6 Click Add or press <Enter>.

7 Repeat steps 3 and 6 to add more searches.

8 When finished, click Save, and then click Close.

9 When ready, run batch processing. (See instructions below.)
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Alternative: Import a file of searches 

Create a text file of searches and import them into the Enter Bibliographic Search 
Keys window:

1. Create an ASCII text file (file extension *.txt) using a basic text editor such as 
Windows Notepad. 

2. Enter searches in command line format, each on a separate line. Save the file.

3. In the Enter Bibliographic Search Keys window of the client, click Import.

4. In the Windows Open window, type the full path and file name of the text file, or 
click Browse and navigate to the file, and then click Open. The client appends 
the searches in the text file to any searches already in the Enter Bibliographic 
Search Keys window.

Enter Library of Congress (LC) authority file searches

Alternative: Create a text file of searches and import them into the Enter Authority 
Search Keys window (see instructions following the procedure above for 
bibliographic records).

Action

1 Click Batch > Enter Authority Search Keys.

2 Check to be sure the local file you want to use is selected in the Local File list, if you 
use more than one local bibliographic save file.

3 In the Query box, enter a search using full search syntax, as you would enter a 
Command Line search for an interactive WorldCat search (logged on). (See the 
Search WorldCat client system guide for more information.)

4 Optional. Select a default index in the Use default index list. The index is used for 
all searches unless you override it by including a different index in a search string.

5 Click Add or press <Enter>.

6 Repeat steps 3 and 5 to add more searches.

7 When finished, click Save, and then click Close.

8 When ready, run batch processing. (See instructions below.)
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Prepare record 
actions for batch 
processing

For batch processing record actions, you "mark" or "set" the actions on records.

Set actions on bibliographic records

Remove record(s) from batch processing

Remove the "Ready" status to remove actions from records that you marked for 
batch processing:

1. Display the record or select records in the file list.

2. Click Action > Set Status or press <Alt><Shift><S>. 

3. In the Set Status window, under Remove ready status for batch, click the check 
boxes next to action(s) you want to remove. 

4. Click OK. 

Action

1 Save the records you want to mark with actions for batch processing in the local 
bibliographic save file: Click Action > Save Record to Local Save File or <F4>.

2 While offline, display a bibliographic record from the local save file (Cataloging > 
Search > Local Save File or <F3>).
Or
Select records in the local bibliographic save file list.

3 On the Action menu, including the Holdings submenu, click the action you want to 
batch-process for the record(s).
Batch-supported actions for bibliographic records are:
 Holdings > Update Holdings 
 Holdings > Delete Holdings
 Holdings > Produce 
 Replace Record
 Export (must have the option for batch export selected in Tools > Options > 

Batch) 
 Label Print (must have the option for batch label printing selected in Tools > 

Options > Batch) 
 Submit for Review 
The status for the action you set changes to R (Ready) in:
 The status bar at the bottom of the displayed record.

Or
 The column for the action in the displayed bibliographic local save file list.

4 When finished marking records, run batch processing. (See instructions below.)
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Set actions on authority records

See instructions for removing record(s) from batch processing following the 
procedure above for setting actions on bibliographic records.

Run batch processing After you prepare searches and/or record actions, run batch processing:

Action

1 Save the records you want to mark with actions for batch processing in the local 
authority save file: Click Action > Save Record to Local Save File or <F4>).

2 While offline, display an authority record from the local save file (Authorities > 
Search > Local Save File or <Shift><F3>).
Or
Select records in the local authority save file list.

3 On the Action menu, click the action you want to batch-process for the record(s).
Batch-supported actions for authority records are:
 Add to Authority File (supported for NACO-affiliated libraries only)
 Replace Record (supported for NACO-affiliated libraries only)
 Export (must have the option for batch export selected in Tools > Options > 

Batch)  
 Submit for Review 
The status for the action you set changes to R (Ready) in:
 The status bar at the bottom of the displayed record.

Or
 The column for the action in the displayed authority local save file list.

4 When finished marking records, run batch processing. (See instructions below.)

Action

1 Click Batch > Process Batch (or press <Alt><B><P>).

2 In the Local Files list, click check boxes to select as many local files as you want to 
process. You can batch process any or all local save files, whether they are 
bibliographic or authority, and whether they are set as default or not.

3 Under Process, click one or more check boxes to select the types of processing you 
want to run:
 Online Searches
 Online Record Actions

When selected, the check box for Check date in Replaced becomes available. 
Select it to have the system check the master record in WorldCat for a more 
recent date. If one is found, the Replace action fails and the client downloads the 
more recent version of the record to your local file.

 Exports (must have the option for batch export selected in Tools > Options > 
Batch)  

 Label Printing (must have the option for batch export selected in Tools > 
Options > Batch)
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Results of batch 
processing

 The batch runs immediately and includes all selected local files.

 The client closes all local file records and lists.

 The Connexion Client Batch in Process window shows the type of processing 
and the full path and file name of the file in process. For searches, the window 
shows the number of records being downloaded of the total retrieved. 

 If you selected the option to display and/or print batch reports in Tools > Options 
> Batch, the reports display and/or print as soon as processing is completed.

 The status of record actions is updated from R (Ready) to C (Completed) or F 
(Failed) in the local save file records and on the local save file list the next time 
you open them.

 The client does not keep your settings in the Process Batch window (helps 
prevent re-running a batch by mistake). You must select the processes you want 
to run each time.

Exception: The client retains your file selection, if you clicked to select the Retain 
file selection check box in the Process Batch window.

 Searches are deleted from the local file unless you set options to keep searches 
that failed (Tools > Options > Batch). 

4 Select the processing order for actions on records and for returning search results. 
Under Process:
For bibliographic records, select one of the following:
 Date/Time Added (default)
 Save File Number
 OCLC Control Number 
 Name
 Title 
For authority records, select one of the following:
 Date/Time Added (default)
 Save File Number
 OCLC ARN
 Heading 

5 When finished, click OK to run batch processing for the selected local files. The 
client shows the progression of the batch in the Connexion Client Batch in Progress 
window.
To cancel processing during a batch run, click Cancel Batch in the Connexion 
Client Batch in Process window.

6 For records marked for some actions, the client may ask if you want to save the 
records to the local file after the batch is finished.
Click Yes to save or No to delete after the batch is completed.

Action
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Quick batch for 
holdings actions

You can batch-process setting or deleting holdings using OCLC numbers only 
without the system having to download the records to your workstation:

To prepare an import file:

1. Create a text file (file extension *.txt) in a text editor such as Notepad, entering 
each OCLC number on a separate line.
Or
Output a text file of OCLC numbers from your local system.

Note:  Enter the numbers only. The system ignores any characters preceding the 
OCLC numbers, such as an index label (no:), an asterisk (*), a number sign (#), 
or a prefix such as ocm.

2. Import the file in the client Batch Holdings by OCLC Number window, as 
described in step 1 of the procedure above.

Roadmap of more 
detailed instructions 
for batch processing

Detailed procedures for the various steps in preparing for and running batch 
processing are integrated into the relevant client guides on searching and taking 
actions on WorldCat and LC authority file records. See the following topics in client 
guides on the Web (or see the same topics in Help) for more details:

 In the Cataloging: Search WorldCat guide—"Enter WorldCat batch search keys"

 In the Authorities: Search Authority Files guide—"Enter LC authority file batch 
search keys"

 In the Cataloging: Take Actions on Bibliographic Records guide—"Take actions 
on bibliographic records" topic, "Set actions on records for batch processing" 
section

 In the Authorities: Take Actions on Authority Records guide—"Take actions on 
authority records" topic, "Set actions on authority records for batch processing" 
section

 In any of the guides listed above—"Run batch processing"

Action

1 Click Batch > Holdings by OCLC Number.

2 In the Batch Holdings by OCLC Number window, enter a list of OCLC numbers, 
each on a separate line.
Or
In the Input File of OCLC Numbers box, enter the full path and file name of a file 
you prepared, or click Browse to locate the file, and then click Import. (See how to 
prepare an import file below.)

3 Click OK to start batch processing right away.
Note:  You must process the numbers immediately. The client does not store them.
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