Latin America and Caribbean

EZproxy 5.4.1 já está disponível

 

A solução líder da comunidade de bibliotecas para autenticação e acesso foi aprimorada novamente.

Foram relatados e resolvidos diversos problemas do EZproxy versão 5.4.1, já disponível. As correções do EZproxy 5.4.1 incluem o seguinte:

  • A função de reiniciar agora reinicia o EZproxy corretamente nas plataformas Windows.
  • O arquivo IPC (denominado ezproxy.ipc) já está sendo criado nas plataformas Windows. Isto resolve a possibilidade de iniciar diversas instâncias do EZproxy em um servidor a partir do mesmo diretório.
  • A autenticação do Shibboleth com grupos agora é concluída, em vez de apresentar a página logup.htm.
  • Correção: O limite do número de entradas includeFile foi inadvertidamente ajustado para um valor muito menor na V5.4. Os limites definidos na V5.4.1 são de 4096 arquivos include permitidos com até 64 includes aninhados - arquivos include com outra declaração include.
  • Alteração: Agora, se o EZproxy for reiniciado e já existir um arquivo IPC, o EZproxy enviará uma mensagem sugerindo que você exclua este arquivo se souber que o EZproxy não está sendo executado no momento. Antes desta alteração, o EZproxy não inicializava nem enviava uma mensagem relacionada.

Problemas com correção prevista para a versão EZproxy 5.5 no final deste ano:

  • O operador de concatenação de sequência é interpretado como um caractere pertencente à constante de texto vizinha em vez de um operador de concatenação. Se você perceber este problema, a solução é inserir um espaço delimitando o operador. Por exemplo, esta sintaxe:

    UserFile("groups/" . login:instNumber.".txt")

    funciona, enquanto

    UserFile("groups/".login:instNumber.".txt")

    não funcionaria.
  • Quando os usuários se autenticam usando o Shibboleth 1.3, cada autenticação resulta na gravação da mensagem: "SAMLResponse no encrypted Assertion elements" (SAMLResponse sem elementos de declaração criptografados) no arquivo messages.txt. Esta mensagem pode ser ignorada e será removida.
  • O EZproxy não funciona com Shibboleth IdP versão 2.3 (em nenhum dos sistemas operacionais suportados). Entendemos o problema e estamos implementando uma alteração para resolvê-lo.

Outras notas:

  • Alguns locais estão relatando que a autenticação do Shibboleth não estava funcionando com o EZproxy V5.3 no sistema operacional Solaris. Confirmamos que a versão do EZproxy V5.4.1 para Solaris funciona com nosso IdP de teste. Por favor, tenha em mente que o problema com o Shibboleth IdP V2.3 acima aplica-se também à versão do EZproxy para Solaris.
  • A mensagem "SAML received assertion without a status of success, denying access" (SAML recebeu declaração sem status de sucesso, negando acesso) é registrada quando ocorre uma falha de autenticação do Shibboleth. Este problema existe desde a V5.1d e foi relatado em instituições na federação UK Access. A OCLC está pesquisando este problema atualmente e em breve emitirá uma atualização no EZproxy ou descreverá um método de configuração para resolver este problema.

Encorajamos você a atualizar para o EZproxy 5.4 .1 e manter-se em dia com os recursos mais recentes. Por favor, leia a página de melhorias e faça a atualização conforme sua conveniência.

O serviço hospedado EZproxy está disponível

Uma versão hospedada do EZproxy já esta disponível. As bibliotecas que se inscreverem para a versão hospedada serão atualizadas automaticamente e com simplicidade com cada novo lançamento do serviço. Elas também têm a vantagem de suporte 24 horas por dia, 7 dias por semana e 365 dias por ano para autenticação fora do local de conteúdo eletrônico sem necessidade de infraestrutura de servidores ou de TI. A versão hospedada EZproxy está disponível nos EUA, e a maior disponibilidade está planejada para mais adiante.

Envie uma mensagem para EZproxy [arroba] oclc.org para solicitar uma cotação do serviço hospedado para sua instituição e organize-se para participar do próximo Webinar do EZproxy, marcado para 17 de agosto de 2011, para que todas as suas perguntas sejam respondidas sobre o lançamento 5.4 e como a versão hospedada pode funcionar em sua biblioteca.