Canada

Sortie de la version 5.4.1 d'EZproxy

 

La solution de gestion des authentifications et des accès, leader dans la communauté des bibliothèques, vient d'être encore améliorée.

La version 5.4.1 d'EZproxy, disponible dès maintenant, corrige plusieurs problèmes qui avaient été signalés sur la version antérieure. Voici quelques-unes des améliorations apportées à EZproxy sur la version 5.4.1 :

  • La fonction Redémarrer permet maintenant à EZproxy de redémarrer correctement sur les plateformes Windows.
  • Le fichier IPC (appelé ezproxy.ipc) peut désormais être créé sur les plateformes Windows. Cela corrige la possibilité de lancer plusieurs fois EZproxy sur un serveur à partir du même répertoire.
  • Le service Shibboleth avec les groupes réalise maintenant l'authentification au lieu d'être présenté avec logup.htm.
  • Améliorations : le nombre limite d'entrées 'includeFile' avait été par erreur fixé beaucoup plus bas sur la version V5.4. Les limites établies sur la version V5.4.1 sont de 4096 fichiers d'inclusion autorisés à une profondeur maximum de 64 fichiers Include imbriqués - fichiers d'inclusion avec une autre directive Include.
  • Modifications : si EZproxy est redémarré et qu'il existe un fichier IPC, EZproxy va désormais afficher un message vous suggérant de supprimer ce fichier si vous savez qu'EZproxy n'est pas actuellement en cours de fonctionnement. Avant cette modification, EZproxy n'affichait pas de message de la sorte.

Éléments devant être améliorés avec la sortie de la version 5.5 d'EZproxy plus tard dans l'année :

  • L'opérateur de concaténation de chaînes est interprété comme un caractère appartenant à la constante textuelle avoisinante et non comme un opérateur de concaténation. Si vous rencontrez ce problème, la solution consiste à insérer un espace autour de l'opérateur. Par exemple, la syntaxe suivante :

    UserFile("groups/" . login:instNumber.".txt")

    fonctionne, alors que

    UserFile("groups/".login:instNumber.".txt")

    ne fonctionne pas.
  • Lorsque les utilisateurs s'authentifient à l'aide de Shibboleth 1.3, le message suivant s'affiche : "SAMLResponse no encrypted Assertion elements" being written to the messages.txt file. Ce message peut être ignoré et va disparaître.
  • EZproxy ne prend pas en charge la version 2.3 du fournisseur d'identité (IdP) de Shibboleth (sur aucun de nos systèmes d'exploitation pris en charge). Nous comprenons le problème et sommes en train de mettre en place des modifications pour le résoudre.

Autres remarques :

  • Certains sites ont indiqué que le service d'authentification Shibboleth ne fonctionnait pas avec EZproxy V5.3 sur le système d'exploitation Solaris. Nous avons vérifié, la version Solaris d'EZproxy V5.4.1 fonctionne avec notre fournisseur d'identité (IdP) test. Veuillez noter que la question concernant l'IdP de Shibboleth V2.3 ci-dessus s'applique également à la version Solaris d'EZproxy.
  • Message "SAML received assertion without a status of success, denying access" logged with a failure to authenticate with Shibboleth. Ce problème existe depuis la version 5.1d et a été signalé par des établissements de la UK Access Federation. OCLC étudie actuellement ce problème et publiera bientôt une mise à jour d'EZproxy ou une méthode de configuration permettant de résoudre ce problème.

Nous vous invitons à effectuer la mise à niveau vers EZproxy 5.4.1 pour bénéficier de ses dernières fonctionnalités. Veuillez consulter la page des améliorations et procéder à la mise à niveau dès que possible.

Le service hébergé EZproxy est maintenant disponible

Une version hébergée d'EZproxy est maintenant disponible. Les bibliothèques qui s'abonnent à la version hébergée sont mises à niveau automatiquement et de manière transparente vers chaque nouvelle version du service. Elles bénéficient également d'une assistance 24h/24, 7j/7 toute l'année pour l'authentification hors site de contenus électroniques sans nécessiter de serveurs ni d'infrastructure informatique. La version hébergée d'EZproxy est actuellement disponible aux États-Unis et il est prévu d'étendre cette disponibilité prochainement.

Envoyez un courriel à EZproxy [AT] oclc.org pour demander un devis relatif au service hébergé pour votre établissement, et préparez-vous à assister au prochain Webinaire EZproxy, programmé pour le 17 août 2011, pour obtenir des réponses à toutes vos questions sur la version 5.4 et sur la manière dont la version hébergée pourrait être utilisée dans votre bibliothèque.