Latin America and Caribbean

Ya se encuentra disponible EZproxy 5.5

 

La solución de acceso y autenticación líder de la comunidad bibliotecaria ha sido mejorada nuevamente.

Las nuevas funciones agregadas a EZproxy 5.5 incluyen incluso más compatibilidad con Shibboleth, como:

  • La configuración predeterminada de Shibboleth 2.3 para IdPs ahora es compatible con EZproxy.
  • El NameIdentifier (ID no persistente) ahora está expuesto para la implementación de Shibboleth de EZproxy a través de la variable de expresión auth:nameid.
  • Los datos HTTP POST ahora pueden superar los 64 kb para Shibboleth. Los demás datos de HTTP POST siguen estando limitados a 64 kb.
  • La autenticación de Shibboleth 1.3 ya no genera innecesariamente el mensaje "SAMLResponse no encrypted Assertion elements" en el archivo messages.txt.
  • La autenticación de Shibboleth ahora es satisfactoria para las instituciones de la UK Access Federation, en lugar de registrar el mensaje potencial "SAML received assertion without a status of success, denying access".
  • En los casos donde se utiliza la directiva XDebug o si se utiliza el argumento de la línea de comandos -D y no existe el archivo "shibuser.txt", el procesamiento de Shibboleth ya no se deshabilitará.

Soluciones de problemas generales:

  • El operador de concatenación de cadenas se interpreta como un carácter que corresponde a la constante de texto cercana y no como un operador de concatenación para los siguientes espacios de nombres.

       auth:, group:, http:, cookie:

    Este antiguo comportamiento se solucionará en la versión 5.5.x solo para los siguientes espacios de nombres.

       login:, env:, ParseName:, session:, db:, re:

    Si detecta este problema, la solución es insertar un espacio alrededor del operador de concatenación. Por ejemplo, esta sintaxis funciona:

       UserFile("groups/" . login:instNumber.".txt")

    Mientras que esta no: 

       UserFile("groups/".login:instNumber.".txt")
  • Se eliminaron mensajes extraños del archivo messages.txt sobre "License Validation" (validación de licencias).
  • Ahora se acepta la incorporación de frases largas de más de 8192 caracteres (aproximadamente) en el archivo messages.txt.
  • El argumento de la línea de comandos "stopall" va a detener todos los procesos denominados "ezproxy". Luego eliminará los archivos ".ipc" y ".lck" del directorio EZproxy desde el que se ejecutó el archivo ejecutable. Los archivos ".ipc" y ".lck" para los demás directorios de ejecución no sufren modificaciones.  Por lo tanto, es posible que usted deba eliminarlos manualmente de esos directorios.
  • En esta versión también se solucionaron varios problemas de seguridad adicionales.

Nota acerca de las versiones

EZproxy V5.5 es la última versión compatible con Solaris SPARC V8. La próxima versión de la primavera del 2012 será la última compatible con Solaris SPARC V10. La compatibilidad con las versiones Solaris Intel no se ha modificado.

Le recomendamos que realice la actualización a EZproxy 5.5 para estar al día con las últimas funciones. Analice la página de mejoras y actualice su versión lo antes posible.

Ya está disponible el servicio alojado de EZproxy

Ya está disponible una versión alojada de EZproxy. Las bibliotecas que se suscriben a la versión alojada, reciben la actualización de manera automática y sin inconvenientes, con cada lanzamiento nuevo del servicio. Además, disfrutan de asistencia las 24 horas del día, los 7 días de la semana, los 365 días del año, para la autenticación de contenido electrónico fuera del establecimiento, sin necesidad de servidores ni infraestructura de TI. La versión alojada de EZproxy está actualmente disponible en EE. UU. y se planea que haya mayor disponibilidad en el futuro.