UK and Ireland

  • English

EZproxy 5.7.42 available

 

EZproxy 5.7.42 includes a number of improvements and fixes:

  • Built with OpenSSL v0.9.8za, which is the latest production version of OpenSSL v0.9.8.
  • Updated version report. This version will report EZproxy 5.7.42 GA [SOURCE:5.7.41_SOURCE] when you use the –v flag to report the version.
  • Resolved issue with cookie expiration headers. Expirations for domain level cookies are now honored.
  • Resolved an issue where EZproxy 5.7.2 disabled TLS when Option DisableSSLv2 is present.
  • Corrected issue with strict-transport-security headers. In previous versions, when a web server sends a strict-transport-security header, this results in the browser only using https for communication with any request to a web server with the same name as the one that sends this header. In the case of proxy by port, this header indicates that all communication with all ports must be https, which ends up blocking all communication to ports that use only http. Now EZproxy does not pass strict-transport-security headers back to the browser.

EZproxy Hosted service is available

A hosted version of EZproxy is available. Libraries that subscribe to the hosted version are automatically and seamlessly upgraded with each new release of the service. They also enjoy 24 x 7 x 365 support for off-site authentication of electronic content with no servers or IT infrastructure required.

Upgrade now

We encourage you to upgrade to EZproxy 5.7.42 or move to the hosted version to stay current with the latest features. Please review the enhancements page and upgrade at your earliest convenience.

Get more details and view a full list of changes.